Description

Vampire weakness weather dependant Patch v1.1     version 1.1     By Birthofinsanity     This mod requires morrowind, Tribunal, Bloodmoon, Vampire Realism II,   Vampiric Hunger III, Vampire Embrace and   Vampire ...