Description

This mod requires morrowind and either VAO Vampire weakness weather   dependant v1.7.1 or Vampire weakness weather dependant v1.8.1  onwards     NPC's will speak to you while you are wearing a helm. Adds a new spell 'Vampiric Visage' that will allow you to spe...