Description

Just select this add-on along with Morrowind Additions and Blood and Gore 1.8+ in Morrowind Launcher. *** THIS ADD-ON REQUIRES THAT YOU ALSO USE BLOOD & GORE v1.8 OR MORE *** It may seem obvious to many, but hey, it won't harm to precise it ;-p These add-on does N...