2008-06-10 00:00:00
You must have Cali's BB V.2 Dryad Dresses installed to use this mod.       Works with Better Bodies version 2.0 or higher.       This mod adds winged versions of my dryad dresses for the Dryads and the normal non beast Morrowind race...