2011-05-11 18:24:07
Magical Goods v1.0 By Star Boi This is no longer beta, and you most definitely should not encounter any problems, however if you do, see the end of the readme please. The mod requires both Tribunal and Bloodmoon expansions This mod also requires that you have both ...